Centos系统下载大全 | Redhat系统下载大全 | Windows2012系统下载大全 | Windows2008系统下载大全| CMS教程 | 网站地图 51运维网-专注Linux/Unix系统安全运维!
当前位置:51运维网 > 专题 > Citrix Xen > 正文

CloudStack + XenServer如何配置交换机和服务器连线

时间:2015-03-07 00:02 来源:网络整理 作者:51ou.com 阅读:

本文将根据设计文档, 对交换机进行配置和服务器网络连线方式进行说明.

Step1.交换机规划,  根据功能将交换机端口分为三个部分:

管理区域(交换机1 – 16 口):  用于XenServer和CloudStack的管理流量, 和VM 在主机间迁移产生的流量.

工作区域(交换机17 - 32 口):  用于VM之间访问和VM访问外部网络产生的网络流量.

存储区域(交换机33 – 48 口): 用于任何与存储交互数据流量.

CloudStack + XenServer如何配置交换机和服务器连线

Step2. 服务器连线.

根据设计服务器配置6块网卡, 其中网卡1, 3 ,5 分别连接到主交换机管理区域, 工作区域和存储区域. 网卡2, 4, 6 分别连接到备交换机管理区域, 工作区域和存储区域.

例如: 服务器XSR01S01网卡连线方式:

第1块网卡连接到R01SW01交换机1口.

第3块网卡连接到R01SW01交换机17口.

第5块网卡连接到R01SW01交换机33口.

———————————————-

第2块网卡连接到R01SW02交换机17口.

第4块网卡连接到R01SW02交换机17口.

第6块网卡连接到R01SW02交换机33口.

连线比较简单,没有专门去画图。网上找了一张释义图,仅供参考。

CloudStack + XenServer如何配置交换机和服务器连线

Step3. 交换机配置(Cisco 3750x)

vlan 100

name CSManagement

exit

vlan 101

name Rack01Management

exit

vlan 102

name Rack02Management

exit

vlan 91

name publicVlan01

exit

vlan 92

name publicVlan02

exit

vlan 91

name publicVlan01

exit

vlan 92

name publicVlan02

exit

vlan接口配置 (在核心上配置)

interface vlan 100

ip address 172.16.100.1 255.255.255.0

exit

interface vlan 101

ip address 172.16.101.1 255.255.255.0

exit

interface vlan 102

ip address 172.16.102.1 255.255.255.0

exit

interface vlan 91

ip address 111.111.101.1 255.255.255.0

exit

interface vlan 92

ip address 111.111.101.1 255.255.255.0

exit

R01SW01交换机管理区域端口vlan配置

interface range gigabitEthernet 0/1 – 16

description Rack01Management

switchport mode access

switchport access vlan 101

exit

R01SW01交换机工作区域端口vlan配置

interface range gigabitEthernet 0/17 – 32

description Rack01Trunk

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan all (or switchport trunk allowed vlan add 301 – 500, switchport trunk allowed vlan add 91)

exit

R01SW01交换机存储区域端口vlan配置

interface range gigabitEthernet 0/33 – 48

description Rack01Storage

switchport mode access

switchport access vlan 12

exit

 

至此已完成交换机配置和服务器连线, 下一步将开始CloudStack管理节点安装和配置.

感谢您对【51运维网 http://www.51ou.com/】的支持,我们为您免费提供《CloudStack + XenServer如何配置交换机和服务器连线》技术文章,《CloudStack + XenServer如何配置交换机和服务器连线》详细使用和说明,有时《CloudStack + XenServer如何配置交换机和服务器连线》可能不完善、敬请谅解!如果《CloudStack + XenServer如何配置交换机和服务器连线》有错误请给我们留言,我们将尽快修复文章错误,如果您觉得本站不错,请分享给周围的朋友!谢谢!

顶一下
(0)
0%
踩一下
(0)
0%
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
验证码:点击我更换图片